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By the Image Analysis Collaboratory @ Harvard Medical School

This is a collection of exercises for the open-source Fiji software.

The exercises are designed to be used in a classroom setting, but can also be used for self-study.

They are divided into sections, each of which covers a different topic and/or a different aspect of Fiji.

Here is an example illustrating the structure of the exercises:

1.1 - Image inspection

1. open the  single_channel.tif image (drag & drop, or File > Open )

2. Image > Duplicate  (IJ:28.9) (shift + d)

3. Analyze > Histogram  (IJ:30.10) (h)

4. click Live

5. Image > Adjust > Brightness/Contrast  (shift + c)
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play with Maximum , Minimum , Brightness  and Contrast  sliders and with Auto , Set

and Reset

observe the histogram window, what is changing, what is not?

click Apply

what changed?

You can perform each exercise using the provided image(s) (click the image name to download it -

note that downloads may not work properly in Safari) or with your own images.

For certain Fiji commands, references to the ImageJ User Guide are included (e.g. IJ:28.9) as a

helpful resource for learning more about Fiji’s features and capabilities.

If a command has a keyboard shortcut, it is indicated in parentheses in bold (e.g. shift + d).

Have fun!

1 - Working with Single-Channel Images

1.1 - Image inspection
1. open the  single_channel.tif image (drag & drop, or File > Open )

2. Image > Duplicate  (IJ:28.9) (shift + d)

3. Analyze > Histogram  (IJ:30.10) (h)

4. click Live

5. Image > Adjust > Brightness/Contrast  (shift + c)

play with Maximum , Minimum , Brightness  and Contrast  sliders and with Auto , Set

and Reset

observe the histogram window, what is changing, what is not?

click Apply

what changed?
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1.2 - Adjust brightness/contrast of all open images
1. open the three single_channel_...tif  images in folder  for_exercise_1.2 (drag & drop, or

File > Open )

2. for all images: Analyze > Histogram  (IJ:30.10) (h)

click Live

3. for one image: Image > Adjust > Brightness/Contrast  (shift + c)

4. adjust contrast with Maximum , Minimum , Brightness  or Contrast  sliders or Auto

5. click Set

6. check Propagate to all other open images  checkbox

7. click OK

8. what happened to the histograms?

9. what happened to the images?

10. did pixel values change?

11. pick another image and repeat steps 4–7

12. what happened, what is different, is it better/worse?

1.3 - File handling and non-invasive editing
1. File > Open Samples > Blobs  (IJ:26.4) (shift + b)

2. Analyze > Tools > Scale Bar  (IJ:30.14.6)

set Color , Background , Location

check: Overlay , Bold Text

3. File > Save As > Tiff  -> blobs1.tif  (IJ:26.10.1)

saving the image as tiff keeps the scale bar as an overlay, so pixel values below it are kept

NOTE: you can see the ovarlay scale bar in the saved image only if you open it in Fiji

continue with 1.4
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1.4 - File handling and invasive editing
1. open the blobs1.tif  saved in 1.3 (drag & drop, or File > Open )

2. Image > Info (IJ:28.3) (i)

3. Image > Overlay > Remove Overlay  (IJ:28.14.7)

the scale bar should disappear since it was saved as an overlay

4. Analyze > Set Scale  (IJ:30.8)

set scale such as image is 100 um long in each dimension

5. Analyze > Tools > Scale Bar  (IJ:30.14.6)

set Color , Background , Location

uncheck Overlay

6. File > Save As > Tiff  -> blobs2.tif  (IJ:26.10.1)

7. load again to check the difference (e.g. check info, hover over the scale bar and look at the pixel

values)

2 - Working with Multi-Channel Images

2.1 - composite images - channels display, splitting
and merging

1. File > Open Samples > Fluorescent Cells  (IJ:26.4)

2. Image > Color > Channels Tool  (IJ:28.7.5)

3. toggle the Channel  checkboxes to show/hide the respective channel

4. change the dysplay mode:

using the dropdown menu, switch between Composite , Color  and Grayscale  modes

and observe the changes in the image display

5. select back the Composite  dysplay mode

6. Image > Color > Arrange Channels

click on New 1 , and select Magenta  to change the LUT of the first channel

7. re-arrange the order of the channels:



in the New channel order  settings, modify the order of the channels by changing the order

of the 123  numbers (e.g. 213)

click OK  to apply the changes

8. split channels

Image > Color > Split Channels  (IJ:28.5.1)

9. merge channels to composite

Image > Color > Merge Channels  (IJ:28.5.2)

check create composite  checkbox (IJ:28.5.2)

10. LUT (look-up table) (IJ:19.17 & IJ: 28.15)

change LUT  of the channels ( LUT  in the startup tools  or Image > Lookup Tables )

11. color blindness

convert to RGB Color: Image > Type > RGB Color  (IJ:7)

Image > Color > Simulate Color Blindness

Image > Color > Dichromacy

2.2 - RGB images - Replace Red with Magenta
1. File > Open Samples > Fluorescent Cells  (IJ:26.4)

2. convert to RGB Color: Image > Type > RGB Color  (IJ:7)

3. Image > Color > Replace Red with Magenta

3 - Image Processing: Filters

3.1 - Edge filters - vertical stripes
1. open the  vertical_stripes.tif image (drag & drop, or File > Open )

2. Image > Duplicate  (IJ:28.9) (shift + d)

3. apply horizontal Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):
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click on OK .

do you understand the output of this process?

4. select the original vertical_stripes.tif  image and duplicate it again.

Image > Duplicate  (IJ:28.9) (shift + d)

5. apply vertical Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):

click on OK .

do you understand the output of this process?

3.2 - Edge filters - horizontal stripes
The steps in this exercise are identical to 3.1, only the input image differs.

1. open the  horizontal_stripes.tif image (drag & drop, or File > Open )

2. Image > Duplicate  (IJ:28.9) (shift + d)

3. apply horizontal Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):

click on OK .

do you understand the output of this process?
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4. select the original vertical_stripes.tif  image and duplicate it again.

Image > Duplicate  (IJ:28.9) (shift + d)

5. apply vertical Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):

click on OK .

do you understand the output of this process?

3.3 - Edge filters - checkerboard
The steps in this exercise are identical to 3.1 and 3.2 only the input image differs.

1. open the  checkerboard.tif image (drag & drop, or File > Open )

2. Image > Duplicate  (IJ:28.9) (shift + d)

3. apply horizontal Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):

click on OK .

do you understand the output of this process?

4. select the original checkerboard.tif  image and duplicate it again.

Image > Duplicate  (IJ:28.9) (shift + d)

5. apply vertical Prewitt filter:

Process > Filters > Convolve

as kernel input (Prewitt):
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click on OK .

do you understand the output of this process?

3.4 - Morphological filters - Binary
1. open the  exercise_morphology.tif image (drag & drop, or File > Open )

2. duplicate the image 4 times and name each copy as follow:

Eroded

Dilated

Closed

Opened

3. apply binary morphological filters:

Process > Binary  (Erode, Dilate, Close, Open)

Note: Make sure you apply the operation that corresponds to the name of each image.

4. report findings

3.5 - Morphological filters - Gray
1. open the  exercise_morphology.tif image (drag & drop, or File > Open )

2. apply Gray Morphological filters:

Process > Morphology > Gray Morphology

3. apply image opening with circular structuring element with radius 3 - removes noise

4. Report: did it get rid of the noise?

5. apply image opening with circular structuring element with radius 5

6. report: did it get rid of the tentacles from the top-left object?

7. with the line tool (IJ:19.2.1), measure the diameter of the holes in the bottom-right object.

8. apply image closing with circular structuring element with radius slightly larger than the
measured radius (diameter/2).
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9. report: did it get rid of the tentacles from the top-left circle?

4 - Segmentation

4.1 - DAPI segmentation with thresholding
1. open the DAPI.tif image (drag & drop, or File > Open )

2. change LUT  to Grays

3. Image > Duplicate  (IJ:28.9) (shift + d)

4. Image > Adjust > Threshold  (IJ:28.2.4)

5. understand the function of the Dark Background  checkbox (inspect pixel values)

6. try setting sliders manually. Can you find a good threshold range?

7. try different algorithms by selecting them in the left dropdown menu. Can you find one that gives

a good result?

NOTE: Image > Adjust > Auto Threshold , if you want to see all at the same time

8. try different display options ( Red , B&W , Over/Under ) by selecting them in the right dropdown

menu, do you understand what they show?

9. when happy with result, click Apply

10. save the resulting binary image: File > Save As > Tiff

11. apply watershed to divide touching objects

select the binary image

Process > Binary > Watershed

12. proceed with Analyze > Analyze Particles  (IJ:30.2)

select Exclude on Edges  and Add to Manager

click on OK

13. bonus: repeat step 12 but use the Size  and Circularity  options to try to exclude some

particles and the Show  dropdown menu to visualize different outputs.

14. set the parameters you want to measure:

Analyze > Set Measurement  (IJ:30.2)

select Area , Mean gray value , Min & max gray value , Display label

click on OK
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15. select the original image (open it again as in step 1 if you do not have it)

16. in the ROI Manager , click on Deselect  and then on Measure

17. save the Results  table as .csv: select the table and click on File > Save As

4.2 - DAPI segmentation with filters and thresholding
1. open the DAPI_noise.tif image (drag & drop, or File > Open )

2. change LUT to Grays

3. Image > Duplicate  (IJ:28.9) (shift + d)

4. Image > Adjust > Threshold  (IJ:28.2.4)

5. understand the function of the Dark Background  checkbox (inspect pixel values)

6. try setting sliders manually. Can you find a good threshold range?

7. try different algorithms by selecting them in the left dropdown menu. Can you find one that gives

a good result?

NOTE: Image > Adjust > Auto Threshold , if you want to see all at the same time

8. apply a filter of your choice ( Mean , Gaussian Blur , Median , …)

Process > Filters

check the Preview  checkbox

change the Radius  / Sigma . What happens to the image?

when you are happy, click on OK

9. repeat steps 3, 7 and 8 until happy with result, then click Apply

10. save the resulting binary image: File > Save As > Tiff

11. apply watershed to divide touching objects

select the binary image

Process > Binary > Watershed

12. proceed with Analyze > Analyze Particles  (IJ:30.2)

select Exclude on Edges  and Add to Manager

click on OK

13. bonus: repeat step 12 but use the Size  and Circularity  options to try to exclude some

particles and the Show  dropdown menu to visualize different outputs.

14. set the parameters you want to measure:

Analyze > Set Measurement  (IJ:30.2)
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select Area , Mean gray value , Min & max gray value , Display label

click on OK

15. select the original image (open it again as in step 1 if you do not have it)

16. in the ROI Manager , click on Deselect  and then on Measure

17. save the Results  table as .csv: select the table and click on File > Save As

4.3 - DAPI segmentation with Labkit
1. open the  hela.tif image (drag & drop, or File > Open )

2. change LUT  to Grays

3. Plugins > Labkit > Open Current Image With Labkit

4. sidebar, under Segmentation : click Labkit Pixel Classification

5. topbar: select the pencil tool

6. sidebar: select foreground . Draw a line inside a nucleus

7. sidebar: select background . Draw a line outside a nucleus

8. sidebar: click the play button next to Labkit Pixelclassification

9. repeat the last three steps until happy with result

10. click the drop down menu next to Labkit Pixel Classifier . Select Show Probability Map

in ImageJ

11. inspect the probability maps, do you understand the meaning of the values of the pixels in the

different channels?

12. export the segmentation: click the drop down menu next to Labkit Pixel Classifier :

Segmentation > Show Segmentation Results in ImageJ

13. inspect results, do you understand the meaning of the pixel values?

you now have a binary image, but not the kind Fiji likes

to measure, proceed by thresholding ( Image > Adjust > Threshold... ): “set” both

threshold values to 1, then Analyze Particles, etc

alternatively, multiply all values in the Labkit output image by 255, then apply Binarize, etc

14. save the resulting image with name “myLabkitHeLa1.tif”: File > Save As > Tiff
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4.4 - DAPI double-segmentation with Labkit
1. open the  hela.tif image (drag & drop, or File > Open )

2. change LUT  to Grays

3. Process > Enhance Contrast . check Equalize histogram . Then, OK

4. Plugins > Labkit > Open Current Image With Labkit

5. sidebar, under Segmentation : click Labkit Pixel Classification

6. sidebar, under Labeling : click add label

7. rename Label 1  by doublecklicking. For instance into cytoplasm . Optional: choose a different

label color by clicking onto the color swatch.

8. topbar: select the pencil tool

9. sidebar: select foreground . Draw a line inside a nucleus

10. sidebar: select cytoplasm . Draw a line inside the cytoplasm

11. sidebar: select background . Draw a line where there is no cell

12. sidebar: click the play button next to Labkit Pixelclassification

13. repeat the last four steps until happy with result

14. click the drop down menu next to Labkit Pixel Classifier . Select Show Probability Map

in ImageJ

15. inspect the probability maps, do you understand the meaning of the values of the pixels in the

different channels?

16. export the segmentation: click the drop down menu next to Labkit Pixel Classifier :

Segmentation > Show Segmentation Results in ImageJ

17. inspect results, do you understand the meaning of the pixel values?

you now have an image with three values

to measure, proceed by thresholding ( Image > Adjust > Threshold... ) at 0, 1, and 2, to

extract each class (use Set and then set both thresholds to 0, 1, or 2)

then proceed with Analyze Particles, etc for each of the classes of interest (nuclei and

cytoplasm)

18. Bonus round: play with Settings
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5 - Spot Detection

5.1 - Manual spot detection with the Multi-point Tool
1. read all the next steps before beginning

2. open the beads_001.tif  image in folder  spot_detection (drag & drop, or File > Open )

3. right-click (ctrl-click) on the Point Tool  in the tool bar and select MultiTool  (IJ:19.5)

4. double-click on the Point Tool  in the toolbar  and customize to your liking (test on image,

clear points by shift + a )

5. count all beads by clicking on them one by one

6. how long did it take you to click on all the beads (measure with stopwatch the time it took to

complete the previous step)?

7. add the points to the ROI Manager  (e.g. press t  on your keyboard)

NOTE: only one ROI will be added, it contains all the points

8. save the ROI to file (in the ROI Manager window, More > Save )

9. click measure in the ROI Manager  to get number of spots

5.2 - Algorithmic spot detection with Find Maxima
useful Find Maxima info on the image.sc forum.

1. open the beads_001.tif  image in folder  spot_detection (drag & drop, or File > Open )

2. Process > Find Maxima

3. check Preview point selection

4. try different values for Prominence  and the three checkboxes

5. try each of the possibilities in the pull-down (remember to click OK  to apply your selection)

what is the difference and what could the different outputs be used for?

tip: shift + u allows you to pin sub-menus of the control panel for quick selection (e.g. the

Process menu)

6. add you detected maxima to the ROI Manager  and save to file
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using your preferred settings, set the Output type  to Point Selection  and press OK

add the points to the ROI Manager  (e.g. press t  on your keyboard)

NOTE: only one ROI will be added, it contains all the points.

save the ROI to file (in the ROI Manager window, More > Save ).

7. load saved ROIs from the manual detection exercise (5.1) (e.g. drag & drop on Fiji the ROIs
.zip  file)

8. compare results: how many beads do you get and how does the number compare to your

manual count?

5.3 - Automatic spot segmentation with thresholding
1. open the beads_001.tif  image in folder  spot_detection (drag & drop, or File > Open )

2. Image > Adjust > Threshold  (IJ:28.2.4)

select Otsu, then Apply

3. Analyze > Set Measurements  (IJ:30.7)

select Area , Mean gray value , Display label

click on OK

4. Analyze > Analyze Particles  (IJ:30.2)

select the Overlay Masks  option in the Show  dropdown menu

select Display results , Clear Results , Summarize , Add to Manager

5. save the ROIs to file (in the ROI Manager window, More > Save )

6. Compare results to the previous two approaches (5.1 and 5.2)

Do they differ significantly from each other?

Which performed better?

5.4 - Spot detection with noise
1. Repeat 5.2 with the with_noise_8000.tif  image in folder  spot_detection

consider smoothing the image first. You can try any of the filter in the Process > Filters

menu:

e.g. Process > Filters > Gaussian Blur , Process > Filters > Mean , …
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NOTE: the Smooth  operation under the Process > Smooth  is a mean filter wuth

radius 1 (3x3 kernel)

2. Repeat 5.3 with the with_noise_8000.tif  image in folder  spot_detection

consider smoothing the image first. You can try any of the filter in the Process > Filters

menu:

e.g. Process > Filters > Gaussian Blur , Process > Filters > Mean , …

NOTE: the Smooth  operation under the Process > Smooth  is a mean filter wuth

radius 1 (3x3 kernel)

3. Compare and comment on the performance of the two methods

Which one is better?

Why/how is it better?

5.5 - Spot detection with variable background
1. Repeat 5.2 with the beads_001_ramp.tif  image in folder  spot_detection

2. Repeat 5.3 with the beads_001_ramp.tif  image in folder  spot_detection

3. Compare and comment on the performance of the two methods

Which one is better?

Why/how is it better?

4. What could be done to the image to make thresholding work better?
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