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Get the course materials

https://hms-iac.github.io/fiji-workshop
One-stop resource for everything we'll cover today 

• Download all slides (PDF) 
• Download all exercises (PDF) 
• Download all images (ZIP)

https://hms-iac.github.io/fiji-workshop


I.A.C. (Image Analysis Collaboratory)  
@ HMS since Sep ‘22

● Support and collaboration: for image and data analysis projects 
● Teaching: at HMS and internationally 
● IT: access to relevant solutions, open- and closed-source 
● R&D: centered on methods and tools 
● Locations: LHRRB 105 & Armenise 531D 
● Consults: Contact Simon 
● simon@hms.harvard.edu 

https://iac.hms.harvard.edu/ 

mailto:simon@hms.harvard.edu
https://iac.hms.harvard.edu/


Who we are, currently
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Backgrounds in 

Physics 
Biology 
Microscopy 
Bioengineering 
Computer Engineering 



Learning objectives

1. Motivate the use of algorithms in image analysis 
2. Introduce some image-analysis nomenclature  
3. Learn to use Fiji effectively and reproducibly



Reasons for Learning About Image Processing

▪ Make pretty pictures (processing)
▪ publications, talks, websites, ...

▪ Get numbers out of pictures (analysis)
▪ cell sizes, vessel lengths, GPF expression level, ...

▪ Make experiment possible (automation)
▪ whole-genome screen: millions of images

▪ Objectivity and Reproducibility
▪ in science, just do it!



Reasons for Not Learning About Image Processing

▪ …

none
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Self-introductions

1. My name is Donald Duck 
2. My position is as a 10th year postdoc 
3. My lab is Mad City Labs 
4. My model system is blue whales  
5. I have data from confocal microscopy



Optical Illusions 
— 

Why should you analyze images  
with computers



Color perception and pattern recognition is individual –  
science less so

https://www.moillusions.com/perfect-circles-optical-illusion/

xxx



Concentric circles !?

https://www.moillusions.com/perfect-circles-optical-illusion/

xxx



Identical central discs?

http://www.brainbashers.com

Our size estimate is strongly influenced by the local neighbourhood



http://www.brainbashers.com

Yes, the discs are identical

Identical central discs?



Is the dot half-way up?

http://www.brainbashers.com

Our sense of distance depends on neighbourhood



Is the dot half-way up?

http://www.brainbashers.com

Yes it is!



Which car is bigger?

BrainBashers Illusion #106

   Are the three cars the same size?
Used with permission. © Julie Clark.

Printed from BrainBashers [www.brainbashers.com]

http://www.brainbashers.com



Which car is bigger?

BrainBashers Illusion #106

   Are the three cars the same size?
Used with permission. © Julie Clark.

Printed from BrainBashers [www.brainbashers.com]

http://www.brainbashers.com



All cars are same size
(Erroneous, application of subjective/perceptual constancy algorithm by your brain)

BrainBashers Illusion #106

   Are the three cars the same size?
Used with permission. © Julie Clark.

Printed from BrainBashers [www.brainbashers.com]

http://www.brainbashers.com

Which car is bigger?



Are A and B equally grey?

http://www.brainbashers.com

Intensity perception depends strongly on neighbourhood



Are A and B equally grey?

http://www.brainbashers.com

Yes they are!



Spot the animal 
— 

Why you should still use your brain  
(a pre-trained neural network) 



Pattern Recognition

http://www.brainbashers.com
Yes, that is a cow!



Pattern Recognition

http://www.brainbashers.com
Yes, that is a cow!



Using Prior Knowledge

http://www.brainbashers.com

Keyword: Dalmatian dog!



Using Prior Knowledge

http://www.brainbashers.com

Keyword: Dalmatian dog!



A brief history of image 
analysis 

— 
ImageJ centric



37 years ago…





12 years ago…

● AlexNet is published (2012) 
○ Wins the ImageNet Large Scale Visual Recognition Challenge  
○ Error of 15.3%, more than 10.8 percentage points better than #2 
○ Possible due to GPUs 

● CellProfiler has been around for 6 years (2006) 
● Fiji (Fiji is just ImageJ) has been around for 5 years (2007) 
● scikit-image released 3 years ago (2009) 
● Bitcoin grows from $5 to $13 (remember Silk Road?) (2012) 
● U-Net, GANs, and Jupyter will appear in 2-3 years (2014/15) 
● AlphaGo will beat Lee Sodol in 4 years (2016) 
● QuPath is still 4 years in the future (2016)

https://doi.org/10.1145/3065386
https://cellprofiler.org/
https://fiji.sc/
https://scikit-image.org/
https://jupyter.org/
https://www.deepmind.com/research/highlighted-research/alphago
https://qupath.github.io/


4 years ago…

● CellPose is out (2020) 
○ “Cellpose: a generalist algorithm for cellular segmentation” 
○ Trained on highly varied images of cells,over 70,000 segmented objects 
○ Cells don’t have to be star-shaped 
○ Web-platform and Jupyter notebooks 
○ https://www.nature.com/articles/s41592-020-01018-x  

● ZeroCostDL4Mic available 
○ Paper still a year in the future 
○ Implementation of common DL technologies to microscopy imaging 
○ Relies on GPUs and other infrastructure provided by Google Colab. 
○ https://github.com/HenriquesLab/ZeroCostDL4Mic/wiki  

● Vision Transformers (2020) 
○ “An Image is Worth 16x16 Words: Transformers for Image Recognition at Scale”, Dosovitskiy et al. 
○ https://arxiv.org/abs/2010.11929 

https://www.nature.com/articles/s41592-020-01018-x
https://doi.org/10.1038/s41467-021-22518-0
https://github.com/HenriquesLab/ZeroCostDL4Mic/wiki
https://arxiv.org/abs/2010.11929


Today… 



History of Segmentation
33

https://x.com/BoWang87/status/1773132444717252718 

https://x.com/BoWang87/status/1773132444717252718


English as the next 
programming language  

— 
LLMs, chatbots and foundation 
models for bio image analysis



https://chat.openai.com/

https://chat.openai.com/


Using ChatGPT for Image Analysis
36



Using ChatGPT for Image Analysis
37

GPT-4, May 2024 GPT-4o, Oct. 2024



Using ChatGPT for Image Analysis
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GPT-4, May 2024 GPT-4o, Oct. 2024



Using ChatGPT for Image Analysis
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GPT-4, May 2024 GPT-4o, Oct. 2024



Using ChatGPT for Image Analysis
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GPT-4, May 2024 GPT-4o, Oct. 2024



Using ChatGPT-4o for Image Analysis
41

GPT-4o, Oct. 2024 - prompted to close larger holes



Using ChatGPT-4o for Image Analysis
42

GPT-4o, Oct. 2024 - it helps to know what to ask



BioImage Chatbot
43

https://aicell.io/post/bioimageio-chatbot/ https://arxiv.org/abs/2310.18351 

https://aicell.io/post/bioimageio-chatbot/
https://arxiv.org/abs/2310.18351


napari-omega
44

 

 

  
We stand at a pivotal juncture for Artificial Intelligence. 
Large Language Models (LLMs) such as ChatGPT1–3 can 
now engage in insightful conversations, demonstrating 
an impressive command of human knowledge and logic. 
These large language models (LLM) are adept 
conversationalists and possess an increasingly accurate 
understanding of numerous scientific and engineering 
disciplines4. ChatGPT, a groundbreaking model from 
OpenAI, can not only code in various programming 
languages but also explain and rectify code5. This 
capability is ushering in an era where users, irrespective 
of their programming skills, can instruct computers to 
perform complex tasks that would have previously 
required coding. Natural language is emerging as the hot 
new programming language. Could we harness these 
advancements to make image processing and analysis 
faster, more accessible, and tailor-made to the user's 
task? 
 
We introduce Omega, an LLM-based conversational 
agent capable of performing image processing tasks, 
analyzing images to gather insights, correcting its own 
coding mistakes, and conducting follow-up 
quantifications and analyses. For instance, a user can 
instruct Omega to “segment cell nuclei in the selected 
image on the napari viewer,” then “count the number of 
segmented nuclei,” and finally “return a table that lists 
the nuclei, their positions and areas” (see Fig. 1, and 
Supp Video 1 and 2). Moreover, Omega can provide 
advice and instructions on various image processing and 
analysis topics. A user can ask Omega to create a “step-
by-step plan to segment nuclei in an image,” Omega will 
generate a detailed strategy (see Supp. Video 3). The 
user can then interactively apply these steps, make 
changes in response to the outcomes, and ask follow-up 
questions to complete the task (see also Supp. Video 3). 
Omega can also create on-demand user interface 

widgets from user prompts. For example, a user may ask 
for a “widget that removes segments in a labels layer 
outside of a range of segment areas” (see Fig 1 and Supp. 
Video 4) or for a “widget that color projects a 3D image 
stack so that the hue is proportional to the depth of 
voxel of max intensity” (See Fig 1, and Supp. Video 5). 
On-demand widget generation for user-tailored tasks 
such as specialized image filtering, transformations, 
visualizations, and more (see Supp. Table 1 for 
examples) is one of the most valuable aspects of Omega. 
To facilitate the reuse, modification, and sharing of 
generated widgets and code snippets, Omega also 
includes an AI-augmented code editor that keeps all 
functional code generated by Omega, allowing users to 
rerun the code, modify and improve it using AI-
augmented tools such as automatic code commenting, 
cleanup, fixing, modification, and safety checks (Supp. 
Fig. 2 and Supp. Video 6). Moreover, the editor also lets 
users on the same local network easily share code (see 
Supp. Video 7). 
 
Omega is written in Python as a plugin to napari6 and 
leverages the LangChain Python library7 and OpenAI's 
application programming interface (API). While Omega 
works best with OpenAI's ChatGPT, it can also leverage 
other LLMs, such as Anthropic's Claude models (see 
Supp. Video 8), and other open-source models via 
Ollama. Omega can converse with the user, like 
ChatGPT's popular web interface. We utilize the ReAct 
framework8 to enable multi-step reasoning and task-
specific actions, including access to online sources of 
information and specialized tools for executing code and 
interfacing with napari. Omega can also correct its own 
coding mistakes by receiving feedback on syntax and 
execution errors encountered (Supp. Video 9).  
 

Omega – Harnessing the Power of Large Language Models 
for Bioimage Analysis 
 

Loïc A. Royer1, *  
 
1Chan Zuckerberg Biohub, San Francisco, USA. 
*Correspondence: loic.royer@czbiohub.org   
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Supplementary Video 1. Omega can segment nuclei with StarDist and perform follow-up analysis. The video showcases 
Omega's ability to segment cell nuclei in a 2D image using Stardist. Omega successfully segments the nuclei and adds a label 
layer to the napari viewer. With further instructions, Omega can count the segmented nuclei and create a CSV file on the 
desktop folder of the machine. This file contains coordinates and areas of all segments, sorted by decreasing area, with one 
segment per row. Omega also opens the file using the system’s default CSV viewer. The video has been sped up by a factor of 
2. 

 
 
Supplementary Video 2. Omega can segment nuclei in a 3D image. This video shows how Omega segments the nuclei in a 3D 
image displayed in the napari viewer. Omega uses a specialized tool for cell and nuclei segmentation and employs a 'classic' 
approach that combines single thresholding, specifically Otsu, with watershed splitting to prevent under-segmentation. After 
segmentation, Omega adds a labels layer to the viewer, and we inquire about the number of segments detected. The response 
is 27. The video has been sped up by a factor of 2. 

 

 

 
 
 

 

 
 
 

 

Supplementary Figure 3. Omega’s System Architecture. Diagram illustrating the Omega system architecture, encompassing 
both the user interface and backend components. The user interface is displayed at the top, consisting of the napari viewer, 
chat window, and AI-enhanced code editor. Key backend elements include the Omega ReAct agent, web server, AI tools 
within the editor, and the Python code repair module. The architecture employs a cascaded design, with a central dialog 
loop orchestrated by a primary language model. This model coordinates a suite of specialized tools, each powered by a 
secondary tool-specific language model that can access online resources, interact with the napari viewer, and integrate 
functionalities from third-party libraries such as Cellpose and StarDist. 

10.5281/zenodo.10828225

https://doi.org/10.5281/zenodo.10828225


Human red blood cells 
DIC microscopy
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https://segment-anything.com/

https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
https://bbbc.broadinstitute.org/bbbc/BBBC009
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
http://dx.doi.org/10.1038/nmeth.2083
https://segment-anything.com/


https://segment-anything.com/

https://segment-anything.com/


Segment Anything in ImageJ/Fiji
47

https://github.com/segment-anything-models-java/SAMJ-IJ 

Released around March 14th, 2024 
Graphical User Interphase 
No coding required

Example of point annotations

https://github.com/segment-anything-models-java/SAMJ-IJ


Pre-processing Processing Post-processing Measuring Analysing & Visualising

Image Analysis Workflow

• There are typically five steps in an image analysis 
• Often a good idea to structure work along these lines before starting

Think of this even before you acquire the images! 

otherwise image analysis may become only a post-mortem on your experiment



• Data-wrangling in general 
• Image format conversion, incl. lossless compression
• Renaming

• Restoration and Reconstruction
• Tomographic reconstruction
• Registration (3D stacks)
• Stitching (tiled images)
• Illumination correction
• Intensity normalisation
• Deconvolution
• Filtering (smoothing, sharpening, etc)
• Grayscale morphological operations

• Color deconvolution
• Channel alignment (chromatic aberrations)
• …

Pre-processing Processing Post-processing Measuring Analysing & Visualising



• Image Segmentation
• Thresholding
• Pixel Clustering
• Edge detection
• Region growing
• Level set methods
• Watershed
• Model based
• Multi-scale
• Trainable pixel-classification

• Spot detection
• Tracking
• …

Pre-processing Processing Post-processing Measuring Analysing & Visualising



• Filtering detected objects based on
• Size, shape, intensity
• Texture, location, neighbours 

• Binary morphological operations
• Open/close
• Skeletonise
• Hit-or-miss transform

• …

Pre-processing Processing Post-processing Measuring Analysing & Visualising



• Object measures
• Size, shape, intensity
• Texture, positions
• Local neighbourhood

• Image measures
• Object count
• Area covered
• Total intensity

• Co-localisation
• …

Pre-processing Processing Post-processing Measuring Analysing & Visualising



• Exploratory data analysis
• Filtering of numerical data based on measured values
• Summary statistics
• Plotting numerical values
• Making movies and montages of images
• Record entire work-flow for later reference
• Write down what you did and why (each step) 
• Use a version control system
• Document your code

• …

Pre-processing Processing Post-processing Measuring Analysing & Visualising



Processing vs. Analysis

Meijering and van Cappellen. Biological Image Analysis Primer.  (2006)

8 BIOLOGICAL IMAGE ANALYSIS PRIMER

Figure 1.2 Illustration of the meaning of commonly used terms. The process of digital image
formation in microscopy is described in other books. Image processing takes an image as input
and produces a modified version of it (in the case shown, the object contours are enhanced using
an operation known as edge detection, described in more detail elsewhere in this booklet). Image
analysis concerns the extraction of object features from an image. In some sense, computer graph-
ics is the inverse of image analysis: it produces an image from given primitives, which could be
numbers (the case shown), or parameterized shapes, or mathematical functions. Computer vision
aims at producing a high-level interpretation of what is contained in an image. This is also known
as image understanding. Finally, the aim of visualization is to transform higher-dimensional im-
age data into a more primitive representation to facilitate exploring the data.

surveillance, forensics, military defense, vehicle guidance, document process-
ing, weather prediction, quality inspection in automated manufacturing pro-
cesses, et cetera. Given this enormous success, one might think that computers
will soon be ready to take over most human vision tasks, also in biological in-



Debugging Fiji and getting help — a workflow

1. Restart Fiji 
2. Ask you right neighbor 
3. Ask you left neighbor 
4. Ask an instructor 
5. Search https://forum.image.sc/

https://forum.image.sc/


Install and Update Fiji



https://imagej.net/Fiji https://fiji.sc/

Fiji is distributed as a portable application, 

which means that you do not have to run an installer. 

Just download (zip file), unpack and start it.

Download Fiji



Update Fiji 
(and install/uninstall plugins)

Help > Update…

Apply Changes:  Install/Update the 
listed plugins  

Manage Update Sites: opens a list of 
plugins, you can select which one(s) 
to install in Fiji

To update Fiji and/or the plugins.

You can have more 
than one Fiji app!



Graphic User Interface (GUI)

Menu Bar

Status Bar Search Bar

Startup Tools
Tools Bar



Graphic User Interface (GUI)

Search Bar 
(L key shortcut)

**Plugins > Utilities > Find Commands - search for Fiji Commands

*Plugins > Shortcuts > List Shortcuts - list of the default shortcuts



Open a file in Fiji
Drag and Drop the file you want to open onto the Status Bar.



Bio-Format Plugin
https://imagej.net/Bio-Formats

import a file - options

Import data from many life 
sciences file formats 

(e.g. @NIC .nd2 format)



Bio-Format Plugin
https://imagej.net/Bio-Formats

import a file - options



import a file

Drag and Drop If you have a tif file, “Drag and Drop” 
does not open Bio-Format Importer.

File > Import > Bio-Formats

Plugins > Bio-Formats >  Bio-
Formats Importer

or

Bio-Format Plugin
https://imagej.net/Bio-Formats



what is an image?



6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

=

=

Pixel = Picture Element

A digital image is a matrix of numbers!



Images in publications and presentations  
should be used to communicate a finding...  

not be the finding

6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

this is your data this is your result this just helps to  
communicate the result



Individual Pixel Values in Fiji



Where do these number come from?

6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

=

=

A digital image is a matrix of numbers!



Bit depth



The detectors used in fluorescence microscopy are monochromatic. 

Cameras or PMTs are not able to distinguish between different 
wavelengths (they just collect photons), you need fluorescence filters to 
separate your fluorophores.  

The detector converts photons in digital numbers (linear relation).

Detectors in 
Fluorescence Microscopy

The range of possible digital values is defined by the bit depth.

Each pixel in the digital image has one digital 
value that depends on the intensity of the 
signal emitted by the sample.

=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Digital Values = Pixel Intensity Value



Bit Depth
The bit depth defines the range of possible digital values that 

each pixel can have, usually 8, 12 or 16 bit. 

The bit depth is expressed in grey values.

bit depth of the image = bit depth of the detector 
(Unless you change that during acquisition)

 x bit = a range of 2x grey values

8 bit image = each pixel can have 28 grey values = 256 grey values = range 0-255 

12 bit image = each pixel can have 212 grey values = 4096 grey values = range 0-4095 

16 bit image = each pixel can have 216 grey values = 65536 grey values = range 0-65535

=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Digital Value = Pixel Intensity Value = Grey Value



Image Metadata

Show the Metadata stored with the file 

(cmd) + i

e.g. bit depth, camera bit depth

Image > Show Info…



display your images
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=

LUT = how the grey values are displayed

LUTs do not change the pixel values



Display a file: Brightness & Contrast

Image > Adjust > Brightness/Contrast (cmd) + shift + c

 Interactively change the displayed  
brightness and contrast of the active image.

*You are NOT changing the pixels values, you are just 
changing how the image is displayed  

(unless you click on the “Apply” button).

0 4095
0

255

2048 30721024

128

64

192

Captured Intensity Value

D
is

pl
ay

 In
te

ns
ity

 V
al

ue

0 4095
0

255

2048 30721024

128

64

192

Captured Intensity Value

D
is

pl
ay

 In
te

ns
ity

 V
al

ue

Change MAX

0 4095
0

255

2048 30721024

128

64

192

Captured Intensity Value

D
is

pl
ay

 In
te

ns
ity

 V
al

ue

Change MIN



Histogram

Pixel Values

Pi
xe

l C
ou

nt

jaehyuk-lee: https://jaehyuk-lee.com/animated-
image-histogram/

foregroundbackground

Analyze > Histogram h



Histogram

Bit depthFiji auto-adjust the range (default option)

Analyze > Histogram h



Display a file: Brightness & Contrast

Mean: 4803 4803
Display range: 188-16828 188-45514

Mean: 4803 4803
Display range: 188-16828 188-16828

45514

16828

Which image has more fluorescence?



Mean: 4803 2074
Display range: 188-19540 112-7768

Mean: 4803 2074
Display range: 188-19540 188-19540

7768

19540

Do NOT trust your eyes, 

rely on numbers!

Which image has more fluorescence?

Display a file: Brightness & Contrast



Display a file: Brightness & Contrast
“Set” button - visually compare images

If you save the images as jpeg/png/tiff,  
they will maintain the display range you set.

Use the same acquisition parameters 
(per channel) if you want to compare images!!! 

(e.g. same exposure time, Illumination intensity,…)

Channel 1 

Channel 2

Exposure time 
Condition1

Exposure time 
Condition2

100 ms 

200 ms

100 ms 

200 ms

Example

For a meaningful comparison, you have to 
extract numbers from your images (analysis). 

Use the images to support your results.



1.1 image inspection 

1.2 adjust brightness/contrast of all open images



=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Images and Colors 
Lookup Tables (LUTs)

LUT = how the grey values are displayed

LUTs do not change the pixel values
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123 186 192 169



Images and Colors

Image > Lookup Tables

“LUT” menu in Startup Tools Bar
or

Ex
am

pl
es

 o
f L

UT
s

*Image > Color > Display LUTs -  to display default LUTs available

Lookup Tables (LUTs)



The human eye evaluates intensity best in grayscale

Images and Colors in Fiji
Choose the right LUT

Which is brighter?

If you are imaging for example a blue fluorophore, you 
are NOT FORCED to display it in blue!



Images and Colors in Fiji

Color blind people don’t distinguish some colors

Choose the right LUT

"If a submitted manuscript happens to go to three 
male reviewers of Northern European descent, 

the chance that at least one will be color blind is 
22 percent"



Images and Colors in Fiji

Color blind people don’t distinguish some colors

Protanope (no red) Tritanope (no blue)

Choose the right LUT

Image > Color > Dichromacy or Image > Color > Simulate Color Blindness





Talley Lambert



RGB Images (still matrix of numbers)

RGB image

RGB Color image (e.g. jpeg, png) = Red + Green + Blue

LUTs cannot be applied to RGB Images

RGB Color image = 8 bit Red, 8 bit Green, 8 bit Blue =  R (0-255), G (0-255), B (0-255)

Image > Type > RGB Color     or      Save As…png, jpeg



Images and Colors in Fiji
The Color menu

Image > Color > Split Channels 

Image > Color > Merge Channels

Split or Merge the channels of the active image



Image > Color > Channels tools

(cmd) + shift + z

Interactive visualization/handling of 
each image channel.

Choose how to display your multicolour 
image: “Color” mode (single channel) vs 

“Composite” mode (overlay)

Images and Colors in Fiji
The Color menu



Segmentation with pixel based classifier—exercises

2.1 composite images - splitting and merging 
2.2 RGB images - Replace Red with Magenta



Pixel Size



Scale Bar and Pixel Size



Pixel Size and Scale Bar
If you want to make some physical measurements of your sample (length, size, …), 

you need to know the pixel size of your image.

Pixel width (Pixel x) = 0.0515 µm 
Pixel height (Pixel y) = 0.0515 µm 
Voxel depth (Pixel z) = 0.0515 µm 

1 µm = 19.4201 pixel (xy) 
(1 µm / 0.0515 µm)

Show the Metadata stored with the file.

(cmd) + i

Image > Show Info…
w/ Metadata



Pixel Size and Scale Bar
If you want to make some physical measurements of your sample (length, size, …), 

you need to know the pixel size of your image.

Open the image properties windows 
containing pixel size properties (and 

multi-dimensional properties)

You can set/read the image 
pixel size in xyz.

(cmd) + shift + p

Image > Properties…



Scale Bar and Pixel Size
What if the pixel size is not stored in the metadata?

If you know the magnification and the camera you used for the acquisition, you 
can estimate the image pixel size.

image pixel size = camera pixel size/magnification

Magnification = 100x Objective 

Camera = Hamamatsu Orca Flash 4

Example

pixel width and height: 
6.5 µm / 100X = 0.065 µm

If a z-series was acquired, “Voxel 

depth” is the z step size choose for the 

acquisition (cannot estimate).

Image > properties



Scale Bar and Pixel Size
Add pixel information to your images from a reference (same magnification)

Analyze > Set Scale…

Set the pixel size information 
starting from an object with a 

known dimension.

*Perform multiple measures and 
average them to be more precise



Scale Bar and Pixel Size

Analyze > Tools > Scale Bar…

- “Overlay" means that the scale 
bar is not embedded in your 
image. You can remove it: 
“Image >Overlay > Remove 
Overlay”. 

- If you save the image as tiff, the 
scale bar will be saved as an 
overlay. 

- If you save as jpeg/png, the 
image will have the scale bar 
embedded. 

Add scale bar to your images



Segmentation with pixel based classifier—exercises

1.3 file handling and non-invasive editing 

1.4  file handling and invasive editing



Image Processing 
— 

Segmentation

• Segmentation is the division of an image into discrete regions. 

Pre-processing Processing Post-processing Measuring Analysing & Visualising



Segmentation

Semantic InstanceInput

Nuclei

Background Background
Nucleus 1 
Nucleus 2  
Nucleus 3  

… 



How do we get segments?

• Thresholding-based  

• Interactive tools based on classic machine learning 

• Deep-learning based (Stardist, Cellpose) 



Thresholding

https://bioimagebook.github.io/chapters/2-processing/3-thresholding/thresholding.html 

The easiest way to segment an image is often by 
applying a global threshold.  

This identifies pixels that are above or below a fixed 
threshold value, giving a binary image as the output.

https://bioimagebook.github.io/chapters/2-processing/3-thresholding/thresholding.html


Thresholding

Original, 8 bit grayscale 
Blobs: Fiji example

Thresholded

Instance Segmentation in FIJI: keeping white (connected-) objects. 

Instance Segmented



Thresholding method

8 bit image (0 - 255)

Select only a range of digital values in the image.



Thresholding method

8 bit image (0 - 255)

in Fiji: Image > Adjust > Threshold…

The result of the thresholding process is a Binary Mask.

(cmd) + shift + t

Select only a range of digital values in the image.



8 bit image (0 - 255)

Thresholding method
Generate a binary mask.

Binary because the image has only two pixel values,  
one for the selected pixels and one for the “discarded” pixels.

In Fiji the two pixel values are 0 and 255.

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 0 0 0 0 0 0 0 0 0 0 255 255 255 0 0 0 0

0 or 255



Segmentation with thresholding—exercises

4.1 DAPI segmentation with thresholding 

Stop at (including) point 10,  
Do not continue further



Manual thresholding is nonreproducible.  
Typically, each image requires a different threshold

Automatic thresholding uses histogram information  
to set a threshold.  

(Dummy example)

Manual vs. automated thresholding



Thresholding method

Usually, if you apply thresholding to the “ORIGINAL” image (the one you get out of 
the microscope), you won’t be able to precisely select all/only the pixels you are 
interested in.

• Fluorescence label (e.g. DAPI) 
• Background (uneven illumination, 

out-of-focus light, aberration, …) 
• Noise (detector read noise, Poisson 

noise, …)

Image Threshold Binary Mask

What can go wrong?



Interactive tools based on classic machine learning

Annotate Predict



https://www.ilastik.org/ https://qupath.github.io/ https://imagej.net/plugins/labkit/

Standalone: Ilastik For histopathology As a Fiji plugin: 
Labikit

Examples



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation



Labkit Segmentation



Labkit Segmentation



Labkit Segmentation



Tips



4.3 DAPI segmentation with Labkit 

Breakpoint at 12: Create results 



Filters



Where is Waldo?

Hi! I am 
Waldo!

Find me in 
that photo!



Where is Waldo?

Hi! I am 
Waldo!

Find me in 
that photo!



Where is Waldo?

Hi! I am 
Waldo!

Find me in 
that photo!



Linear Transformation

Smoothing: Mean, Gaussian 

Edge detection: Sobel, Canny

Non-linear Transformation

Smoothing: Median 

Cleaning: Morphology

Filtering
Neighborhood Transformation



Convolution is weighted average in local neighborhood

Weights are defined by the kernels 

Weighted average = Multiply, add, divide

One neighborhood at a time 

Neighborhood defined by the kernel size

Terminologies
A kernel is a small matrix used in image processing for convolution.

A filter is a broader term that refers to any technique that modifies an image.



Convolution operation

px1 px2 px3 px4 px5 px6 px7 px8 px9

px10 px11 px12 px13 px14 px15 px16 px17 px18

px19 px20 px21 px22 px23 px24 px25 px26 px27

px28 px29 px30 px31 px32 px33 px34 px35 px36

px37 px38 px39 px40 px41 px42 px43 px44 px45

px46 px47 px48 px49 px50 px51 px52 px53 px54

px55 px56 px57 px58 px59 px60 px61 px62 px63

px64 px65 px66 px67 px68 px69 px70 px71 px72

px73 px74 px75 px76 px77 px78 px79 px80 px81

k1 k2 k3

k4 k5 k6

k7 k8 k9

=

?

(px1 * k1 / ksum) + 

(px2 * k2 / ksum) +  

(px3 * k3 / ksum) + 

(px10 * k4 / ksum) + 

(px11 * k5 / ksum) + 

(px12 * k6 / ksum) + 

(px19 * k7 / ksum) + 

(px20 * k8 / ksum) + 

(px21 * k9 / ksum) = 

c1
ksum = k1 + k2 + k3 + k4 + k5 + k6 + k7 + k8 + k9

3 x 3 kernel

Image

Adapted from Federico M. Gasparoli

convolution



Convolution operation

px1 px2 px3 px4 px5 px6 px7 px8 px9

px10 px11 px12 px13 px14 px15 px16 px17 px18

px19 px20 px21 px22 px23 px24 px25 px26 px27

px28 px29 px30 px31 px32 px33 px34 px35 px36

px37 px38 px39 px40 px41 px42 px43 px44 px45

px46 px47 px48 px49 px50 px51 px52 px53 px54

px55 px56 px57 px58 px59 px60 px61 px62 px63

px64 px65 px66 px67 px68 px69 px70 px71 px72

px73 px74 px75 px76 px77 px78 px79 px80 px81

k1 k2 k3

k4 k5 k6

k7 k8 k9

=

c1 ?

(px2 * k1 / ksum) + 

(px3 * k2 / ksum) +  

(px4 * k3 / ksum) + 

(px11 * k4 / ksum) + 

(px12 * k5 / ksum) + 

(px13 * k6 / ksum) + 

(px20 * k7 / ksum) + 

(px21 * k8 / ksum) + 

(px22 * k9 / ksum) =  

c2
ksum = k1 + k2 + k3 + k4 + k5 + k6 + k7 + k8 + k9

3 x 3 kernel

Image

Adapted from Federico M. Gasparoli

convolution



Convolution operation

px1 px2 px3 px4 px5 px6 px7 px8 px9

px10 px11 px12 px13 px14 px15 px16 px17 px18

px19 px20 px21 px22 px23 px24 px25 px26 px27

px28 px29 px30 px31 px32 px33 px34 px35 px36

px37 px38 px39 px40 px41 px42 px43 px44 px45

px46 px47 px48 px49 px50 px51 px52 px53 px54

px55 px56 px57 px58 px59 px60 px61 px62 px63

px64 px65 px66 px67 px68 px69 px70 px71 px72

px73 px74 px75 px76 px77 px78 px79 px80 px81

k1 k2 k3

k4 k5 k6

k7 k8 k9

=

c1 c2 ?

(px3 * k1 / ksum) + 

(px4 * k2 / ksum) +  

(px5 * k3 / ksum) + 

(px12 * k4 / ksum) + 

(px13 * k5 / ksum) + 

(px14 * k6 / ksum) + 

(px21 * k7 / ksum) + 

(px22 * k8 / ksum) + 

(px23 * k9 / ksum) = 

c3
ksum = k1 + k2 + k3 + k4 + k5 + k6 + k7 + k8 + k9

3 x 3 kernel

Image

Adapted from Federico M. Gasparoli

convolution



Different Types of Kernel
0 0 0 0 0

0 1 1 1 0

0 1 1 1 0

0 1 1 1 0

0 0 0 0 0

0 0 0 0 0

0 1 2 1 0

0 2 5 2 0

0 1 2 1 0

0 0 0 0 0

0 0 0 0 0

0 -1 0 1 0

0 -1 0 1 0

0 -1 0 1 0

0 0 0 0 0

0 0 0 0 0

0 -1 -1 -1 0

0 0 0 0 0

0 1 1 1 0

0 0 0 0 0

0 0 0 0 0

0 1 -1 1 0

0 -1 2 -1 0

0 1 -1 1 0

0 0 0 0 0



Mean Filter



Gaussian Filter



Effects of Different Gaussian Kernel

Kernel Blurred image



Edge Filters
Prewitt Operator



Different Filters in Action

0 0 0 0 0

0 1 1 1 0

0 1 1 1 0

0 1 1 1 0

0 0 0 0 0

Mean Filter Gaussian Filter

0 0 0 0 0

0 1 2 1 0

0 2 5 2 0

0 1 2 1 0

0 0 0 0 0

Prewitt Filter

0 0 0 0 0

0 -1 0 1 0

0 -1 0 1 0

0 -1 0 1 0

0 0 0 0 0

0 0 0 0 0

0 -1 -1 -1 0

0 0 0 0 0

0 1 1 1 0

0 0 0 0 0

Sharpening Filter

0 0 0 0 0

0 1 -1 1 0

0 -1 2 -1 0

0 1 -1 1 0

0 0 0 0 0



Filtering — exercises

3.1 edge filters - vertical stripes 
3.2 edge filters - horizontal stripes 
3.3 edge filters - checkerboard



Filtering — exercises

4.2 DAPI segmentation with filters and thresholding



Labkit segmentation



Interactive tools based on classic machine learning

Annotate Predict



https://www.ilastik.org/ https://qupath.github.io/ https://imagej.net/plugins/labkit/

Standalone: Ilastik For histopathology As a Fiji plugin: 
Labikit

Examples



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation
in Fiji: 


Plugins 

> Labkit 

> Open Current Image With Labkit



Labkit Segmentation



Labkit Segmentation



Labkit Segmentation



Labkit Segmentation



Tips



4.3 DAPI segmentation with Labkit 

Breakpoint at 12: Create results 



1 1 1

1 1 1

1 1 1

Mean

Gaussian Blur

No Filter

Median
[103

106
109

136
152

179
189

209
236]

Threshold Binary MaskFilterImage Find Objects Segment Measure

-1 -1 -1

0 0 0

1 1 1

Prewitt

…

Binary Operations

Watershed 

Watershed 

Watershed 

Watershed 

DilationErosion

DilationErosion

DilationErosion

DilationErosion

Summary

La
bkit

La
bkit

La
bkit

La
bkit



🔗 https://iac.hms.harvard.edu/

The Image Analysis Collaboratory 
is organizing two workshops!

Introduction to Macro writing in ImageJ/Fiji

🗓 January 28th, 10am-5:30pm

📍In Person @ HMS - Registration Required

🔗 https://tinyurl.com/iac-fiji-macro-20250128

⏰ Application Deadline: January 24th

Introduction to Image Analysis using ImageJ/Fiji
🗓 January 22nd & January 24th, 1pm-5:30pm 

📍In Person @ HMS - Registration Required

🔗 https://tinyurl.com/iac-fiji-20250122

⏰ Application Deadline: January 17th

Free for 

Quad A Labs!

Free for 

Quad A Labs!

https://tinyurl.com/iac-fiji-macro-20250128
https://tinyurl.com/iac-fiji-20250122


Morphological Filters



Erosion Dilation

Two Primary Morphological Operations

Erosion Dilation



Erosion Operation



Erosion Operation



Erosion Operation



Erosion Operation



Erosion Operation



Erosion Operation



Erosion Operation



Erosion - The Movie



Dilation Operation



Dilation Operation



Dilation Operation



Dilation Operation



Dilation - The Movie



But wait, 
there is a problem.



Together We Stand
Main image

Main image Eroded image

Dilated image

Opened image

Closed image

Closing: 
Erosion of the dilation.

Opening: 
Dilation of the erosion.



Bonus Example

Main image

Inner edge 

Erode more, dilate less, then subtract

Outer edge 

Dilate more, erode less, then subtract



Structuring Element Size



Structuring Element Shape
Square 

structuring element

Circular 
structuring element



Structuring Element Shape
Square 

structuring element

Circular 
structuring element

BE CAREFUL!



Morphology in Fiji



Morphology — exercises

3.4 - Morphological filters - Binary 
3.5 - Morphological filters - Gray



ROI Manager



Annotation Tools

Region Of Interest (ROI)
Annotation Tools

Double Click to  
set/change properties

Secondary/Right Click 
for more options

*see also Edit > Selection



“Analyze” menu

ROI Manager

t

Analyze > Tools > ROI Manager…

The ROI Manager is a tool for working 
with multiple selections (ROIs).

*(cmd) + t can be used to both to open the ROI Manager and/or add a new ROI to the Manager.

*

**shift + e can be used to draw the last ROI.



ROI Manager

Add new ROI (t).

After modifying a ROI, you can use Update to save the changes.

Delete selected ROI. If none is selected, delete all.

Rename selected ROI.

Deselect one or more selected ROI.

ROI(s) {

“Analyze” menu



ROI Manager
Rectangle… Text

Line

Change the properties of the selected ROI(s)

Dot

“Analyze” menu



ROI Manager
Open a saved ROI.zip file (drag & drop works as well)
Save ROI(s) as a .zip file

“Edit” menu

“Analyze” menu



ROI Manager
Open a saved ROI.zip file (drag & drop works as well)
Save ROI(s) as a .zip file

Set ROI(s) label options

*”Use names as labels” can be also found  
  under “More>Options…”

*Labels option can also be found under “Image > Overlay”

“Image” menu

“Analyze” menu



Live Demo of ROI manager



Segmentation 
And  

Measurements



Process and segmentBinary mask Export and Measure



Process and segmentBinary mask Export and Measure



Do you see an issue here? Process and segment 



Solution: Watershed

Watershed is a useful algorithm to try to separate touching objects.

Image Binary Mask Watershed

in Fiji: Process > Binary > Watershed

Process and segment 



Solution: Watershed

30

20

10

  0

300

200

100

    0

Distance transformBinary mask

Process and segment 



From binary image to instance segmentation

Instance segmentationBinary mask

Process and segment 



in Fiji: Analyze > Analyze Particles…

Process and segment Analyze particles



Analyze particles — underlying principles

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles — underlying principles

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles — underlying principles

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles — underlying principles

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles — underlying principles

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles: Select for morphology 

Fill

Size

Circularity

in Fiji: 

Analyze 

> Analyze Particles…

Process and segment 



Analyze particles: Size

in Fiji: Analyze > Analyze Particles…

Size range of the particles that 
you want to detect.

from to

particle

Process and segment 



Analyze particles: Size

the size range of the particles that you want to detect.

Process and segment 



Analyze particles: Circularity

Circularity of the particles that you want to detect. 

in Fiji: Analyze > Analyze Particles…

Process and segment 



Analyze particles: Circularity

area = 1
perimeter2

Process and segment 



Analyze particles: Circularity

area = 1
perimeter2

Process and segment 



Analyze particles: Circularity

area
perimeter

<

area < 1 area = 1
perimeter2perimeter2

Process and segment 



Analyze particles: Exclude on Edges

“Exclude on edges” excludes objects that are 
touching the borders of the image.

in Fiji: Analyze > Analyze Particles…

Process and segment 



Process and segmentBinary mask Export and Measure



Export and Measure
• Save the segmented image


• Add to ROI manager 


• Generate and export measurements



Analyze particles: Save the segmented image

“Count Masks” encodes object 
identity as gray value.

LUT: 3-3-2 RGB

0 17 0 17

in Fiji: Analyze > Analyze Particles…

Export 



Analyze particles: Add to ROI Manager

“Add to Manager” stores all found objects in the 
ROI Manager.

in Fiji: Analyze > Analyze Particles…

Export 



Analyze particles: Add to ROI Manager

in Fiji: Analyze > Analyze Particles…

Export 



Export and Measure• Save the segmented image


• Add to ROI manager 


• Generate and export measurements



Export and Measure• Save the segmented image


• Add to ROI manager 


• Generate and export measurements


• Select what to measure


• Measure



Select what to measure: Set Measurements

Analyze > Set Measurements… Specifies which measurements have to be performed 
(e.g. area, mean grey value, max and min grey values, …)

Export 



Measure — Option 1: Manually

(cmd) + m

Analyze > Measure

Measures the parameters chosen under  
“Analyze > Set Measurements…”  

in relation to the selected ROI. 

Results are displayed in a Result Table  
(which can be saved as .csv, .xlsx, …)

Export 



Side note: other kinds of measurements

(cmd) + k

Analyze > Plot Profile

*Plots can be saved as .csv file (“Save Data…”) and also as images (e.g. “File > Save AS > PNG”)

Follow “live” image 
changes while moving the 

ROI



Measure — Option 2: from Analyze particles Export 



Measure — Option 3: Using the ROI manager

1. Select the “ORIGINAL” image. 

2. To measure all the ROIs stored in the 
“ROI Manager”, no ROI has to be 
selected in the“ROI Manager”. Use the 
“Deselect” button. 

3. Click on the “Measure” button.  

4. A “Results” table will appear. 

Export 



Segmentation with pixel based classifier—exercises

Continue with the “Analyze Particle” step 
form ONE of the workflow exercises below.

4.1 DAPI segmentation with thresholding 

OR 

4.3 - DAPI segmentation with Labkit 



Spot Detection 
(Point tool and Find Maxima)



Point and Multi-Point tool
Select and Measure multiple points

Mouse right-click

Mouse double-click

*you can also toggle the “Show all” checkbox in the ROI Manager.

to measure all points:

Analyze > Measure

(cmd) + m

**

t

to add point selection to ROI Manager:

to clear all points:

Edit > Selection > Select None

(cmd) + shift + a

*

**you can also use the “Measure” button in the ROI Manager.

“Edit” and “Analyze” menu



Point and Multi-Point tool
Select and Measure multiple points

Process > Find Maxima…

“Process” menu



Segmentation with pixel based classifier—exercises

5.1 - Manual spot detection with the Multi-point Tool 
 
5.2 Algorithmic spot detection with Find Maxima 

5.3 Automatic spot segmentation with thresholding 

5.4. Spot detection with noise 
 
5.5. Spot detection with variable background 



IAC Website - iac.hms.harvard.edu

http://iac.hms.harvard.edu


Further Learning (https://iac.hms.harvard.edu/resources/) 

Forum: Knowledge exchange and support 

○ https://forum.image.sc/  

Online book with code: Introduction to Bioimage Analysis 

○ https://bioimagebook.github.io/  

Online training: NEUBIAS Academy  

○ https://eubias.org/NEUBIAS/training-schools/neubias-academy-home/  

○ https://www.youtube.com/c/NEUBIAS  

Fiji manual from Monash University 

○ https://bridges.monash.edu/articles/educational_resource/Fiji_Training_Manual_v6_4_/20033513 

BioImaging North America (BINA) 

https://www.bioimagingnorthamerica.org/

https://iac.hms.harvard.edu/resources/
https://forum.image.sc/
https://bioimagebook.github.io/
https://eubias.org/NEUBIAS/training-schools/neubias-academy-home/
https://www.youtube.com/c/NEUBIAS
https://bridges.monash.edu/articles/educational_resource/Fiji_Training_Manual_v6_4_/20033513


Feedback Form - Thanks!
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