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Annotation Tools
*see also Edit > Selection

(Fiji Is Ju

|/ Llrla lalo
vl v Straight Line 5
5 Segmented Line

rc
Freehand Line
Arrow tool
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egion Of Interest (ROI)

@ Fiji File Edit Image Process Analyze Plugins Window Help

ri (Fiji Is Just) ImageJ
B ojcolJ4[+/N Al M| o

(Fiji Is Just) Image) 2.1.0/1.53c / Java 1.8.0_66 (64-bit)

Annotation Tools

@ Fiji File Edit Image Process Analyze Plugins Window Help
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x=15.76 (306), y=9.58 (186), value=285
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Analyze

@ Fiji File Edit Image Process

Secondary/Right Click
for more options

mife)

Double Click to

(< ’ o/ 4 ’i}i‘ A ‘ O\’ M ‘ -‘ set/change properties

*Straight*, segmented or freehand lines, or arrows (right ¢
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“Analyze” menu

@ Fiji File Edit Image
O O

ROI Manager

Process Analyze Plugins Window Help

(Fijils JU  Measure

IE Ov| = ‘ ~ ‘ /,| A‘iit‘ N | A| O\ Analyze Particles... ‘ /

&

(Fiji Is Just) Image) 2.1.0/1.53c; Java 1.8.0_66 [

Summarize

Distribution...
Label

ROl Manager...

here to search

Analyze > Tools > ROl Manager...

The ROI Manager is a tool for working
with mulfiple selections (ROls).

r. @ ROl Manager B
0249-0127 Add [t]
0220-0513
0159-0291 Update
0393-0346

Delete
Rename...
Measure
Deselect
Properties...
Flatten [F]
More »
Show All
Labels
A

*(cmd) + t can be used to both to open the ROl Manager and/or add a new ROI to the Manager.

**shift + e can be used to draw the last ROI.

hitps://imagej.net

https://imagej.nih.gov/ij/
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“Analyze” menu

ROI Manager

ROl Manager

0249-0127 Add [t] Add new ROI (1).
0220-0513

0159-0291 Update After modifying a ROI, you can use Update to save the changes.
0393-0346

ROI(s)

Delete Delete selected ROI. If none is selected, delete all.
Rename... Rename selected ROI.
Measure

Deselect Deselect one or more selected ROI.

Properties...

Flatten [F]

More »

Show All

Labels

O ) Image

IJ : hitps:/fimageinet  hitps://imageinih.gov/iy https://fiii.sc/ https://imagej.net/Fij \ A 4 ﬁ:ﬁ'a‘f;:ato,y
|
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“Analyze” menu

0249-0127
0220-0513
0159-0291
0393-0346

ROI Manager

ROl Manager

Add [t]

Update

Delete
Rename...
Measure

Deselect

Rectangle...

Name:
Position:
Group:

Stroke color:

Width:

Fill color:

Properties

0404-0412
none
none

magenta

50

none

List coordinates (4)

No properties

Cancel OK

Text

Properties

Name: 0409-2033
Position: none

Group: none

Stroke color: #ff00e5

Font size: 200 points

Angle: 0 degrees

Justification:  Left

Fill color: none

Antialiased text
List coordinates (4)

No properties

Cancel

OK

Change the properties of the selected ROI(s)

Line Dot
Flatten [F] '. Properties 'O o Properties
N ;1 0078-0596
Name: 0432-1152 .a.me
MOre » - Position: none
Position: none Group: none
Group: none . '
ShOW A” e . — Stroke (point) color: yellow
' Point type:  Hybrid
Labels Width: [ 39 Size:  Small
List coordinates (4)
No properties List coordinates (1)
No properties
Cancel OK
L L Cancel OK
O 3 Image
T : T .o . Analysis
Il l https.//imagej.net https://imagej.nin.gov/ij/ / y

hitps://f
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“Analyze” menu
“Edit” menu

® O

ROI Manager

0249-0127
0220-0513
0159-0291
0393-0346

Add [t]

ROI Manager

Open a saved ROL.zip file (drag & drop works as well)

Update

Delete

Rename...

Measure

Deselect

Properties...

Flatten [F]

| Show All

Labels

More »

Save ROI(s) as a .zip file

JL

hitps://imagej.net

hitps://imagej.nih.gov/ij/

https://fiji.sc/
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“Analyze” menu
“Image” menu

O

0249-0127 Add [t]
0220-0513
0159-0291 Update
0393-0346

ROI Manager

Delete
Rename...
Measure
Deselect
Properties...
Flatten [F]

More »

Show All

Labels

*Labels option can also be found under “Image > Overlay”

*"Use names as labels” can be also found

under “More>Options...”

ROI Manager

Open...
Save...

Fill

Draw

AND

OR (Combine)
XOR

Split

Add Particles
Multi Measure
Multi Plot
Sort
Specify...

Remove Positions...

Labels...

List

Interpolate ROIs
Translate...

Help

Options...

Open a saved ROL.zip file (drag & drop works as well)
Save ROI(s) as a .zip file

Set ROI(s) label options

& Fiji

£+ N A|Q) ™ | o

Bocjol/ swlwi ol 4]a| |»

(Fiji Is Just) Image) 2.1.0/1.53c; Java 1.8.0_66 [64-bit];

34.60x26.36 um (672x512); 16-bit; 672K ROI_1 Add [t]
ROI_2
ROL 3 Update
ROI_4 Delete
Labels Rename...
Measure
Color: vyellow o Deselect
Fohtsizell 24 e Properties...
Flatten [F]
Show labels More »
Use names as labels Show All
Draw backgrounds Labels

Bold

Cancel OK

hitps://imagej.net

https://imagej.nih.gov/ij/

hitps://fiji.sc/ https://imagej.net/Fiji
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Live Demo of ROl manager




O ) Image

Analysis

V.Y Collaboratory

Segmentation
And
Measurements



O ) Image

Analysis
V.Y Collaboratory

Binary mask Process and segment Export and Measure

Results

Area |Mean X
L0016 285 204.29474 197
0028 278 174.84892 219
W '0027 231 188.46753 45.C
& 0034 501 189.14172 174
0041 660 171.69697 73.§
L F 0048 228 195.89474 233,
: 209.03571 138




Binary mask * Process and segment *

O ) Image

Analysis
V.Y Collaboratory

Export and Measure

Results

Area |Mean

X

0016 285 204.29474
0028 278 174.84892
'0027 231 188.46753
0034 501 189.14172
0041 660 171.69697
" 0048 228 195.89474
' 209.03571

197,
219
45.C
174,
73.8
233
138



Process and segment

Do you see an issue here?

O ) Image

1L https://imagej.net https://imagej.nih.gov/ii/ https://fiji.sc/ https://imagej.net/Fij A A 4 Analysis
. Collaboratory
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Process and segment O\ ) Image
Analysis

Solution: Watershed O Collaboratory

In Fiji: Process > Binary > Watershed

Watershed is a useful algorithm to try 1o separate touching objects.

Image Binary Mask Watershed

> >



Process and segment O\ ) Image
Analysis

Solution: Watershed O Coltaboratory

Binary mask Distance transform

o B TR | | 0 g |
i
@ @ "
- | E B | -
== =
E _ _ © 20 |- O _
> 200 5 ¢
300 T R I S S S NN T S 3'0 PR I T SR T N TR W S
0 20 40 60 0 20 40 60

Distance (microns) Distance (microns)



Process and segment O\ ) Image
Analysis

From binary image to instance segmentation V.Y Calsborstoy

Binary mask Instance segmentation



Process and segment O\ ) Image
Analysis

Solution: Analyze particles Y Coltaboratory

Plugins Window Help

in Fiji: Analyze > Analyze Particles... JU Measure &M |
D) . VAFRYERES

—




Process and segment O ) Image

Analyze particles — underlying principles Y colabortory
ibr:naly:ze

> Analyze Particles...




Process and segment O\ ) Image
Analysis

Analyze particles — underlying principles V.Y Colsborstory

N :
Analyze
> Analyze Particles...

r.;jj:j;. (Fiji Is Just) ImageJ Y

S JA oM 4] o

Ooco/«

v

wls]a]e]| |>

Stk

M/and (tracing) tool




Process and segment O ) Image

Analyze particles — underlying principles Y colabortory
Z]naly:ze

> Analyze Particles...




Process and segment O ) Image

Analyze particles — underlying principles Y colabortory
Z]naly:ze

> Analyze Particles...




Process and segment O ) Image

Analyze particles — underlying principles Y colabortory
Z]naly:ze

> Analyze Particles...




O ) Image

Process and segment
Analysis

Analyze particles: Filter for morphology Y coltaboratory
Size ' ;

, Circularity
O @ Analyze Particles

Size (pixelA2): | (2 31ili18%
Circularity: 0.00-1.00

Show: Nothing v
v| Display results v| Exclude on edges Fl”
Clear results Include holes
Summarize Overlay
v| Add to Manager Composite ROIls

Help Cancel OK




Process and segment

Analyze particles: Size

In Fiji: Analyze > Analyze Particles...

O O Analyze Particles

Size (pixelA2): | (B2 51ili18%

Circularity: 0.00-1.00

Size range of the particles that
you want to detect.

Show: Nothing v
. ¢ 9
V| Display results v| Exclude on edges . » from ’ to
Clear results Include holes
Summarize Overlay \
v| Add to Manager Composite ROIs particle
Help Cancel OK

O ) Image
I u I hitps://imagej.net https://imagej.nih.gov/ij/ hitps://fiji.sc/ https://imagej.net/Fiji V Y é\:Iallaf::atory
, |


https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
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Process and segment

Analyze particles: Size

O Analyze Particles

Size (micronA2):f O-Infinity

Pixel units

N the size range of the particles that you want to detect.

& Fiji

File Edit Image Process

Analyze Plugins Window Help

mlfelfa{io]

WA O M ] o

x=28.60 (88), y=26.98 (83), angle=-42.51

DAPL.tif (200%)

length=13.23

47.45x47.45 microns (146x146); 32-bit; 83K

Lut

b

AVaK)

Stk

hitps://imagej.net

https://imagej.nih.gov/ij/

hitps://fiji.sc/

https://imagej.net/Fiji
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Process and segment

Analyze particles: Circularity

O O Analyze Particles

Size (pixelA2): | (B2 51ili18%

Show: | Nothing Circularity of the particles that you want to detect.

v| Display results v| Exclude on edges
Clear results Include holes
Summarize Overlay
v| Add to Manager Composite ROIls
Help Cancel OK

O ) Image
I u l hitps://imagej.net https://imagej.nih.gov/ij/ hitps://fiji.sc/ https://imagej.net/Fiji V yr ‘C‘:ﬁ'af:sratory
|
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Process and segment

Analyze particles: Circularity

area
41 X = T

perimeter?

O\ ) Image
m' https://imagej.net hitps://imagel.nin.gov/ij/ https://fiji.sc/ https://imagej.net/Fij A A 4 lé:,allaf:iam,y
@
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Process and segment

Analyze particles: Circularity

area
41 X = T

perimeter?

O\ ) Image
ﬁ' https://imagej.net hitps://imagel.nin.gov/ij/ hitps://fiji.sc/ https://imagej.net/Fiji A A 4 ﬁ:,allaf:iatory
@
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Process and segment

Analyze particles: Circularity

ared ared
471 X < T 41 X = T

perimeter? perimeter?

< TH

O\ ) Image
m' https://imagej.net hitps://imagel.nin.gov/ij/ hitps://fiji.sc/ https://imagej.net/Fiji A A 4 ﬁ:,allafzato,y
@
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Process and segment

Analyze particles: Exclude on Edges

IN : Analyze > Analyze Particles...

“Exclude on edges’” excludes objects that are
touching the borders of the image.

O O Analyze Particles

Size (pixelA2): | (B2 51ili18%

Circularity: 0.00-1.00
Show: Nothing v
V| Display results v| Exclude on edges .
Clear results Include holes ) .
Summarize Overlay
V| Add to Manager Composite ROls
Help Cancel OK

O ) Image

u ) hitps:/fimageinet  hitps://imageinih.gov/iy https://fiii.sc/ https://imagej.net/Fij \ A 4 ﬁ:ﬁ'a‘f;iato,y
o |
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Binary mask * Process and segment *

O ) Image

Analysis
V.Y Collaboratory

Export and Measure

Results

Area |Mean

X

0016 285 204.29474
0028 278 174.84892
'0027 231 188.46753
0034 501 189.14172
0041 660 171.69697
" 0048 228 195.89474
' 209.03571

197,
219
45.C
174,
73.8
233
138



O ) Image

Analysis
V.Y Collaboratory

Export and Measure
* Save the segmented image

Mean

85 204.29474

» Add to ROl manager 0 o Copgrrs

195.89474

» Generate and export measurements |~ 0 O LRI




Export

Analyze particles: Save the segmented image

IN : Analyze > Analyze Particles...

O O Analyze Particles

Size (micronA2): O-Infinity
Pixel units

Circularity: 0.00-1.00

Show: Count Masks

Nothing LUT: 3-3-2 RGB
Display resull Overlay edges
Clear res.ults Overlay Masks es ‘ ‘ | | | | | ‘ ‘ | ‘ ‘ | I | | | | | ‘ | ‘
summarize o, tlines — | EE T T b bE b b
Add to Manag p. .. Autlines ROIs 0 17 0 17
Ellipses
Help P K

Masks "Count Masks” encodes object

- identity as gray value.

( O ) Image
’

https://imagej.net https://imagej.nih.gov/ii/ https://fiii.sc/ https://imagej.net/Fij A A 4 ﬁ:ﬁ'a‘f;famy
|
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Export

Analyze particles: Add to ROl Manager

“Add to Manager’ stores all found objects in the

Analyze Particles

ROl Manager.

Size (micronA2):  O-Infinity ® © ® ROl Manager
Pixel units Add [t]
Circularity: 0.00-1.00 Update
Delete
Show: Nothing Rename...
Measure
Display results Exgiide on edges Deselect
Clear results nclude holes Properties...
Summarize Overlay Flatten [F]
Add to Manager Composite ROIs More »
Show All
Help Cancel OK Labels
O ) Image
u I https://imagej.net https://imagej.nih.goVv/ij/ https://fiji.sc/ https://imagej.net/Fiji A A 4 Analysis
. Collaboratory
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Export

Analyze particles: Add to ROl Manager

IN : Analyze > Analyze Particles...

@0 @ Analyze Particles )
Size (micronA2):  O-Infinity
Pixel units

Circularity: 0.00-1.00

Show: Nothing

Display results 4 Exclude on edges

Clear results Include holes

>

@ Fiji File Edit Image

Process Analyze

Plugins

Window Help

r

Ooc o 4N AL

M| o

Stk | LUT

0] 4]0

|>>

Wand (tracing) tool

290.70x290.70 microns (1530x1530); 8-bit (inverting LUT); 2

Summarize Overlay

4 Add to Manager Composite ROIs

Help Cancel OK

o 9
o
o
15
o

0001-0092
0002-0129
0003-0204
0004-0266
0005-0270
0006-0326
0007-0326
0008-0395
0009-0414
0010-0579
0011-0616
0012-0636
0013-0764
0014-0768
0015-0831
0016-0975
0017-0999

@® ROI Manager

Rename...
Measure
Deselect

Properties...

Flatten [F]

Show All
Labels

Add [t]
Update

Delete

More »

hitps://imagej.net https://imagej.nih.gov/ij/

hitps://fiji.sc/

https://imagej.net/Fiji
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O ) Image

Analysis
V.Y Collaboratory

¢ Save the segmented image Export and Measure

» Add to ROl manager .- 9 BT

0016 285 204.29474 197
0028 278 174.84892 219
Il '0027 231 188.46753 45.C

© 0034 501 189.14172 174
660 171.69697 73.8&
228 195.89474 233
209.03571 138

* Generate and export measurements




O ) Image

Analysis
V.Y Collaboratory

» Save the segmented image Export and Measure

» Add to ROl manager , e Wean

0016 285 204.29474 197

0028 278 174.84892 219
W ‘0027 231 188.46753 45.C
0034 501 189.14172 174
660 171.69697 73.§
228 195.89474 233
209.03571 138

Generate and export measurements

e Select what to measure

e Measure




Export

Select what to measure: Set Measurements

Specifies which measurements have to be performed

Analyze > Set Measurements... (e.g. area, mean grey value, max and min grey values, ...)

OOJc|o] /] <[5\ AL

O O Set Measurements

W ] o

Stk

GANAPARI

/| Area V] Mean gray value
Standard deviation Modal gray value
V] Min & max gray value Centroid
Center of mass Perimeter
Bounding rectangle Fit ellipse
Shape descriptors Feret's diameter
Integrated density Median
Skewness Kurtosis
Area fraction Stack position

Limit to threshold |[(v] Display label
Invert Y coordinates Scientific notation
Add to overlay NaN empty cells

Redirect to: DAPI_14.tif v

"~ DAPI.nd2 (seriesl4)"; 260.00x260.00 m

x=109.20 (336), y=15.60 (48), value=0

"~ DAPI.nd2 (series 14)"; 260.00x260.00 m

Label

Decimal places (0-9): 9

Area Mean

DAPI_14.tif
DAPI_14.tif

DAPI_14.tif
NAPI 14 tif

Help Cancel

166.148133307 4870.167832168
142.805007140 6199.803994083

173.964383698 8027.766848816
142 A2R757172 KAR? QRLR2AN?RN

1L hitps://imagej.net https://imagej.nih.gov/ij/

hitps://fiji.sc/

https://imagej.net/Fiji
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Export

Measure — Option 1: Manually

@ Fiji File Edit Image Process Analyze Plugins Window BAR Help

8 0l |ol/ 4]t < ALO|] ] =/se/u| s 4]0 /a]>

(Fiji Is Just) Image) 2.9.0/1.53t; Java 1.8.0_322 [64-bit];

Stk

D © @ DAPLtif (150%)
"~ DAPI.nd2 (series 14)"; 43.88x4

Label Angle Length
DAPLtif -39.472459848 21.472148194

1

Analyze > Measure

(cmd) + m

Measures the parameters chosen under
“Analyze > Set Measurements...” ® © @ DAPLLif (150%)

in relation to the selected ROI. "~ DAPI.nd2 (series 14)"; 43.88x4 Label [Mean Min |Max
.. EAS DAPILtif 1234.255983351 416 1999

Results are displayed in a Result Table
(which can be saved as .csv, .xisx, ...)

1 O ) Image

https://imagej.net https://imagej.nih.gov/ii/ https://fiji.sc/ https://image]j.net/Fij A A 4 ﬁ:ﬁ'a‘f:ﬁato,y
|
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Side note: other kinds of measurements

Analyze Particles...

Anquze > PIO"‘ PrOfiIe § Fiji File Edit Image Process Analyze Plugins Window Help
.~ Measure
<

Summarize

(cmd) + k

Distribution...

Label

Clear Results

Set Measurements...

o

O Plot of hela_cells
2.90x584.02 (485x262); RGB; 496K

Set Scale...
Calibrate...
Histogram

l
1 T L] L] I L] ) 1 1 I T L] T [
700 O Plot Contents Style

Plot Profile
Surface Plot...
Gels

Tools

Item: | Data Set 1: (46 data points) 3

Color: magenta

Secondary (fill) col... none

Line width: 5.0
Symbol: Line 9

3D Objects Counter
3D OC Options
Skeleton

Gray Value
n
-
=

400 i Label:

Colocalization

Visible

o0 — ™" v

0.0 0.5 1.0 Cancel 0K
Distance (urﬁ) ’

Color Histogram

Directionality
Shape Index Map

Helmholtz Analysis
3D Surface Plot
Classification

List Data » More » Live
- Follow “live” image

changes while moving the
Save Data... Contents Style... g RO g

Local Thickness

*Plots can be saved as .csv file (“Save Data...”) and also as images (e.g. “File > Save AS > PNG”)

) O\ ) Image
https://imagej.net https://imagej.nih.gov/ii/ https://fiii.sc/ https://imagej.net/Fij A A 4 ﬁ:ﬁ'a‘f;fawy
|
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Export

Measure — Option 2: from Analyze particles

O Set Measurements

Area

Standard deviation
V] Min & max gray value

Center of mass

Bounding rectangle

Shape descriptors

Integrated density

Skewness

Area fraction

Limit to threshold
Invert Y coordinates
Add to overlay

V] Mean gray value
Modal gray value
Centroid
Perimeter
Fit ellipse
Feret's diameter
Median
Kurtosis
Stack position

V] Display label

Scientific notation
NaN empty cells

Redirect to: DAPI_14.tif

Decimal places (0-9): 9

Help

Cancel

O

Size (micronA2):

Analyze Particles

O-Infinity
Pixel units

Circularity: 0.00-1.00

Display results
Clear results
Summarize

V] Add to Manager

Show: Overlay Masks v

V] Exclude on edges
Include holes
Overlay
Composite ROIs

Help Cancel OK

& Fiji

mifelfa][CIPAP A RNVNJe)

x=109.20 (336), y=15.60 (48), value=0

"~ DAPIL.nd2 (series 14)"; 260.00x260.00 m

M (4 o

Stk

BTVIDCE

"~ DAPI.nd2 (series 14)";: 260.00x260.00 m

0001-0028

o 0002-0031

0003-0103
0004-0143
0005-0155
0006-0187

0007-0302
0008-0347

0009-0381

0010-0456

0011-0459

0012-0497
0013-0502

NAPI 14 +if 142 AQ787172

CAR? QRRIAN? RN

Label Area Mean Min [Max
1 DAPI_14.tif 166.148133307 4870.167832168 3279 7193
2 DAPI_14.tif 142.805007140 6199.803994083 3275 9411
3 DAPI_14.tif 173.964383698 8027.766848816 2965 12624
4

Add [t]

Update

Delete
Rename...
Measure
Deselect

Properties...

Flatten [F]
More »

] Show All

(V] Labels

hitps://imagej.net

https://imagej.nih.gov/ij/

hitps://fiji.sc/

https://imagej.net/Fiji
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Export

Measure — Option 3: Using the ROl manager

@ Fiji File Edit Image Process Analyze Plugins Window Help

Q| c|o| /] £[% | NA|O| M| ofswfur) 7] 4|8

(Fiji Is Just) Image) 2.3.0/1.53n; Java 1.8.0_202 [64-bit];

Stk

312.00x312.00 microns (960x960); 16-bit; 1.8MB

UT); 900K

>

NnNN10 _NEN1

D

__ ® ROI Manager
0001-0056 Add [t]
0002-0090
0003-0123 Update
0004-0143
0005-0163 Delete
0006-0199 Rename...
0007-0210
0008-0215 Measure
0009-0271
0010-0285 Deselect
0011-0283 Properties...
0012-0289
0013-0304 Flatten [F]
0014-0331
0015-0338 st
0016-0364
0017-0377 g Show All
0018-0453 M Labels

. Select the “ORIGINAL"” image.

. To measure dll the ROls stored in the

"ROI Manager”, no ROl has to be
selected in the“ROI Manager’. Use the
"Deselect” button.

Click on the “Measure’” button.

A “Results” table will appear.

hitps://imagej.net

https://imagej.nih.gov/ij/

hitps://fiji.sc/

https://imagej.net/Fiji
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Image
Analysis
Collaboratory


https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/

Segmentation with pixel based classifier—exercises

Continue with the “Analyze Particle” step
form ONE of the workflow exercises below.
7.1 segmentation with thresholding

OR
7.2 segmentation with Weka




