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https://imagej.net/Fiji https://fiji.sc/

Fiji is distributed as a portable application, 

which means that you do not have to run an installer. 

Just download (zip file), unpack and start it.

Download Fiji

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Update Fiji 
(and install/uninstall plugins)

Help > Update…

Apply Changes:  Install/Update the 
listed plugins  

Manage Update Sites: opens a list of 
plugins, you can select which one(s) 
to install in Fiji

To update Fiji and/or the plugins.

“Help” menu

You can have more 
than one Fiji app!

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Graphic User Interface (GUI)

Menu Bar

Status Bar Search Bar

Startup Tools
Tools Bar

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Graphic User Interface (GUI)

Search Bar 
(L key shortcut)

**Plugins > Utilities > Find Commands - search for Fiji Commands

*Plugins > Shortcuts > List Shortcuts - list of the default shortcuts

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Open a file in Fiji
Drag and Drop the file you want to open onto the Status Bar.

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Bio-Format Plugin
https://imagej.net/Bio-Formats

import a file - options

“File” menu
“Plugins” menu

Import data from many life 
sciences file formats 

(e.g. @NIC .nd2 format)

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Bio-Format Plugin
https://imagej.net/Bio-Formats

import a file - options

“File” menu
“Plugins” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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import a file

Drag and Drop If you have a tif file, “Drag and Drop” 
does not open Bio-Format Importer.

File > Import > Bio-Formats

Plugins > Bio-Formats >  Bio-
Formats Importer

or

Bio-Format Plugin
https://imagej.net/Bio-Formats“File” menu

“Plugins” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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what is an image?
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6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

=

=

Pixel = Picture Element

A digital image is a matrix of numbers!
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Images in publications and presentations  
should be used to communicate a finding...  

not be the finding

6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

this is your data this is your result this just helps to  
communicate the result
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Individual Pixel Values in Fiji

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Where do these number come from?

6 13 19 6 19 13 9 19 9 6 9 6 16 16 6 16 13 132 229 103 19 16 13 23 9 9

19 19 6 13 13 13 13 16 16 19 9 13 9 6 16 16 49 192 216 106 23 13 16 16 23 13

13 9 4 13 13 16 19 36 66 93 79 26 13 13 6 16 113 209 196 113 29 19 36 49 36 33

19 13 19 13 16 13 26 89 123 136 152 116 76 33 13 46 159 162 159 126 79 96 189 229 226 212

16 16 9 6 13 19 26 93 156 179 106 66 79 136 106 152 179 93 29 13 16 23 79 156 123 49

16 6 13 13 16 13 23 69 103 69 19 16 6 109 209 236 179 43 9 16 9 13 13 19 13 13

9 9 16 19 13 13 19 13 26 16 16 13 6 103 179 189 132 33 19 16 16 9 9 6 6 6

13 9 4 13 13 13 16 19 13 23 6 16 23 123 186 192 169 126 26 16 19 13 6 13 16 13

13 13 9 16 9 6 13 19 16 19 6 19 63 199 192 106 29 149 162 113 119 53 9 13 6 13

13 9 16 6 6 19 13 9 23 13 9 6 119 182 149 36 6 39 196 196 176 73 16 9 9 9

6 19 13 9 19 16 13 13 19 9 9 23 142 179 109 13 16 9 39 59 23 19 13 4 9 9

19 13 9 9 16 16 16 9 9 13 6 66 169 172 43 16 9 9 9 13 13 19 16 16 16 9

9 9 6 9 13 9 6 13 4 9 19 116 196 89 9 9 16 16 19 19 9 16 6 16 9 9

13 13 9 23 19 13 9 9 9 6 26 159 219 59 23 9 13 9 6 13 6 19 16 13 16 13

9 23 13 6 6 23 9 19 13 16 66 206 179 13 6 16 13 13 13 16 9 13 9 9 16 13

13 13 23 16 19 19 6 9 19 13 142 255 103 19 13 6 19 9 16 9 16 9 16 13 23 9

6 13 23 9 13 16 13 6 9 53 229 246 39 9 13 13 13 13 9 9 19 13 16 13 13 13

13 19 59 76 26 9 16 16 13 99 249 142 6 19 13 13 13 13 19 4 13 13 6 26 9 13

16 113 229 219 93 9 26 83 23 159 219 59 9 9 6 13 16 13 16 13 6 9 9 16 23 9

136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

=

=

A digital image is a matrix of numbers!
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Bit depth
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The detectors used in fluorescence microscopy are monochromatic. 

Cameras or PMTs are not able to distinguish between different 
wavelengths (they just collect photons), you need fluorescence filters to 
separate your fluorophores.  

The detector converts photons in digital numbers (linear relation).

Detectors in Fluorescence Microscopy

The range of possible digital values is defined by the bit depth.

Each pixel in the digital image has one digital 
value that depends on the intensity of the 
signal emitted by the sample.

=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Digital Values = Pixel Intensity Value
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The bit depth defines the range of possible digital values that 
each pixel can have, usually 8, 12 or 16 bit. 

The bit depth is expressed in grey values.

bit depth of the image = bit depth of the detector 
(Unless you change that during acquisition)

 x bit = a range of 2x grey values

8 bit image = each pixel can have 28 grey values = 256 grey values = range 0-255 

12 bit image = each pixel can have 212 grey values = 4096 grey values = range 0-4095 

16 bit image = each pixel can have 216 grey values = 65536 grey values = range 0-65535

=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Digital Value = Pixel Intensity Value = Grey Value
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“Image” menu

Image Metadata

Show the Metadata stored with the file 

(cmd) + i

e.g. bit depth, camera bit depth

Image > Show Info…

x bit image

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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display your images
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109 209 236 179

103 179 189 132

123 186 192 169

=

LUT = how the grey values are displayed

LUTs do not change the pixel values
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Display a file: Brightness & Contrast

Image > Adjust > Brightness/Contrast (cmd) + shift + c

 Interactively change the displayed  
brightness and contrast of the active image.

*You are NOT changing the pixels values, you are just 
changing how the image is displayed  

(unless you click on the “Apply” button).
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“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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“Image” menu

Histogram

Pixel Values

Pi
xe

l C
ou

nt

jaehyuk-lee: https://jaehyuk-lee.com/animated-
image-histogram/

foregroundbackground

Analyze > Histogram h

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Histogram

Bit depthFiji auto-adjust the range (default option)

Analyze > Histogram h

“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Mean: 4803 4803
Display range: 188-16828 188-45514

Mean: 4803 4803
Display range: 188-16828 188-16828

45514

16828

Which image has more fluorescence?
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Mean: 4803 2074
Display range: 188-19540 112-7768

Mean: 4803 2074
Display range: 188-19540 188-19540

7768

19540

Do NOT trust your eyes, 

rely on numbers!

Which image has more fluorescence?

Display a file: Brightness & Contrast
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Display a file: Brightness & Contrast
“Set” button - visually compare images

If you save the images as jpeg/png/tiff,  
they will maintain the display range you set.

Use the same acquisition parameters 
(per channel) if you want to compare images!!! 

(e.g. same exposure time, Illumination intensity,…)

Channel 1 

Channel 2

Exposure time 
Condition1

Exposure time 
Condition2

100 ms 

200 ms

100 ms 

200 ms

Example

For a meaningful comparison, you have to 
extract numbers from your images (analysis). 

Use the images to support your results.

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/


Segmentation with pixel based classifier—exercises

1.3 image inspection 

1.4 adjust brightness/contrast of all open images
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=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

Images and Colors 
Lookup Tables (LUTs)

LUT = how the grey values are displayed

LUTs do not change the pixel values

0 

1 

… 

100 

… 

255

Image 
(8 bit)

Displayed 
color

gr
ey

 LU
T

0 

1 

… 

100 

… 

255

Image 
(8 bit)

Displayed 
color

gr
ee

n 
LU

T

=
136 106 152 179

109 209 236 179

103 179 189 132

123 186 192 169

https://imagej.net/Fiji
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Images and Colors

Image > Lookup Tables

“LUT” menu in Startup Tools Bar
or

Ex
am

pl
es

 o
f L

UT
s

*Image > Color > Display LUTs -  to display default LUTs available

Lookup Tables (LUTs)

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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The human eye evaluates intensity best in grayscale

Images and Colors in Fiji
Choose the right LUT

Which is brighter?

If you are imaging for example a blue fluorophore, you 
are NOT FORCED to display it in blue!
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Color blind people don’t distinguish some colors

Choose the right LUT

"If a submitted manuscript happens to go to three 
male reviewers of Northern European descent, 

the chance that at least one will be color blind is 
22 percent"



Images and Colors in Fiji

Color blind people don’t distinguish some colors

Protanope (no red) Tritanope (no blue)

Choose the right LUT

Image > Color > Dichromacy or Image > Color > Simulate Color Blindness

Image 
Analysis 
Collaboratory





Talley Lambert
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RGB Images (still matrix of numbers)

RGB image

RGB Color image (e.g. jpeg, png) = Red + Green + Blue

LUTs cannot be applied to RGB Images

RGB Color image = 8 bit Red, 8 bit Green, 8 bit Blue =  R (0-255), G (0-255), B (0-255)

Image > Type > RGB Color     or      Save As…png, jpeg

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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“Image” menu

Images and Colors in Fiji
The Color menu

Image > Color > Split Channels 

Image > Color > Merge Channels

Split or Merge the channels of the active image

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Image > Color > Channels tools

(cmd) + shift + z

Interactive visualization/handling of 
each image channel.

Choose how to display your multicolour 
image: “Color” mode (single channel) vs 

“Composite” mode (overlay)

Images and Colors in Fiji
The Color menu

“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/


Segmentation with pixel based classifier—exercises

2.2 composite images - splitting and merging
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Pixel Size
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Pixel Size and Scale Bar
If you want to make some physical measurements of your sample (length, size, …), 

you need to know the pixel size of your image.

Pixel width (Pixel x) = 0.0515 µm 
Pixel height (Pixel y) = 0.0515 µm 
Voxel depth (Pixel z) = 0.0515 µm 

1 µm = 19.4201 pixel (xy) 
(1 µm / 0.0515 µm)

Show the Metadata stored with the file.

(cmd) + i

Image > Show Info…
w/ Metadata

“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Pixel Size and Scale Bar
If you want to make some physical measurements of your sample (length, size, …), 

you need to know the pixel size of your image.

Open the image properties windows 
containing pixel size properties (and 

multi-dimensional properties)

You can set/read the image 
pixel size in xyz.

(cmd) + shift + p

Image > Properties…

“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Scale Bar and Pixel Size
What if the pixel size is not stored in the metadata?

If you know the magnification and the camera you used for the acquisition, you 
can estimate the image pixel size.

image pixel size = camera pixel size/magnification

Magnification = 100x Objective 

Camera = Hamamatsu Orca Flash 4

Example

pixel width and height: 
6.5 µm / 100X = 0.065 µm

If a z-series was acquired, “Voxel 

depth” is the z step size choose for the 

acquisition (cannot estimate).

Image > properties

“Image” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Scale Bar and Pixel Size
“Analyze” menu

Add pixel information to your images from a reference (same magnification)

Analyze > Set Scale…

Set the pixel size information 
starting from an object with a 

known dimension.

*Perform multiple measures and 
average them to be more precise

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/
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Scale Bar and Pixel Size

Analyze > Tools > Scale Bar…

- “Overlay" means that the scale 
bar is not embedded in your 
image. You can remove it: 
“Image >Overlay > Remove 
Overlay”. 

- If you save the image as tiff, the 
scale bar will be saved as an 
overlay. 

- If you save as jpeg/png, the 
image will have the scale bar 
embedded. 

Add scale bar to your images

“Analyze” menu

https://imagej.net/Fiji
https://fiji.sc/
https://imagej.net
https://imagej.nih.gov/ij/


Segmentation with pixel based classifier—exercises

1.6 file handling and non-invasive editing 

1.7  file handling and invasive editing


